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I - Choisir Draw ?
Il existe de nombreux logiciels disponibles sur le « marché ». Il est possible de les classer de différentes façons : selon l'usage, les métiers auxquels ils sont destinés, la licence, le prix, la qualité, le potentiel, la plate-forme pour lesquels ils sont accessibles… On classera Draw dans les logiciels de bureautique de par son appartenance à la suite LibreOffice (ou OpenOffice). Draw n'est pas le logiciel le plus complet de sa catégorie, disons dessin ou mise en page et, pour des graphistes confirmés, il ne pourra rivaliser avec Inkscape ou Scribus. Il n'en met pas moins à disposition des fonctions intéressantes et originales, ainsi que d'autres que l'on trouve dans les autres logiciels du même type , dont certains ont influencé les autres.

II - Un logiciel professionnel
Le monde de la mise en page et du dessin est dominé par deux logiciels connus sous le nom d'Illustrator et d'Indesign ou Xpress. En logiciel libre, Draw remplira environ l'espace du premier et partiellement des autres. Les équivalents libres seraient Inkscape et Scribus. Mais Draw est un logiciel unique en son genre qui ne trouve pas d'équivalent. Cela le rend difficile à classer.
II-A - Pour quels usages ?
L'un des gros avantages de Draw réside dans son intégration à la suite LibreOffice. Ainsi, il est simple à prendre en main pour les personnes qui sont habituées à travailler dans un traitement de texte et un tableur. Il permet aussi de faciliter les échanges entre les différents modules, en tout cas, plus simplement qu'avec les outils plus destinés spécifiquement à la PAO. Pour les graphistes confirmés habitués à Inkscape ou Scribus, Draw permet d'accéder facilement à des outils originaux comme l'extrusion 3D, ou de paramétrer des graphiques ou tableaux avant leur insertion dans une mise en page Scribus. Il n'y a pas de sous-outils, juste des cas d'utilisation différents.
II-B - À quel prix ?
Draw est un logiciel gratuit et facilite donc son adoption par diverses personnes sans sélection par l'argent. Draw est aussi libre, ce qui vous permet de le distribuer autour de vous ou de l'adapter à vos besoins sans avoir à demander l'accord des auteurs, et vous avez tout à fait le droit de l'utiliser dans un contexte professionnel. Des dons peuvent cependant être faits à Draw soit sous forme monétaire par le biais du site officiel, soit sous forme informatique en participant ou finançant des améliorations du logiciel. C'est ainsi qu'il progresse, par les petits apports de chacun. Depuis qu'il est devenu LibreOffice, cela est plus vrai que jamais. Hormis cela, vous aurez tout loisir de profiter de votre budget pour augmenter vos compétences plutôt que de payer un nouveau logiciel. Cette solution est en général valorisée par les logiciels libres, car les logiciels n'y sont considérés que comme des outils et pas comme des solutions. Le véritable maître des opérations, le professionnel est l'utilisateur, non le logiciel. Ce dernier doit juste être à niveau pour permettre au premier d'exprimer sa créativité à sa juste valeur.
Bonne lecture.

III - À propos de ce livre
Ce document est initié par Cédric Gémy, graphiste, formateur et contributeur à Gimp, mais aussi Inkscape et Scribus, qui a déjà écrit plusieurs livres sur le sujet.
En tant que formateur à la mise en page de document, Cédric est régulièrement confronté au problème des dessins à insérer et même si sa préférence va à Inkscape, il n'empêche que Draw possède des spécificités qui le rende parfois plus intéressant, en particulier par sa compatibilité avec le reste de la suite OpenOffice.
Ce livre est organisé globalement sur un principe de double page traitant d'un sujet clair et précis composée généralement d'une page d'explication et d'une page d'illustration. Il a été fait pour vous servir d'aide-mémoire dans votre période d'adaptation à Draw en attendant que vous trouviez vos marques. Il respecte lui-même les principes du logiciel libre et reste modifiable et diffusable par les lecteurs en particulier sur le site fr.flossmanuals.net.

IV - Interface
Comprendre l'organisation du logiciel est essentiel pour s'y repérer et avoir une vision d'ensemble qui permet d'éviter d'avoir à tout apprendre par cœur. Le travail dans Draw va s'organiser autour d'outils qui vont nécessiter l'utilisation de fenêtres variées. Repérer les parties de Draw, c'est comme repérer les parties d'un tableau de bord d'une voiture. Il n'est pas nécessaire de tout connaître, mais il est bon de savoir comprendre les indices importants pour ne pas aller à la catastrophe.
Globalement, Draw s'organise autour d'outils (bouton), de commandes (menus) et de fenêtres de paramétrage et d'organisation.
IV-A - La fenêtre de dessin
La fenêtre dessin est essentielle dans Draw, ce sera le cœur du travail. Elle organise l'accès aux outils et aux différentes options. Avoir une fenêtre de dessin efficace est une clé du succès en vous laissant le loisir de vous concentrer sur l'essentiel, le dessin.
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IV-B - Les outils
Les outils sont placés au démarrage dans la partie inférieure du logiciel et sont présentés sous forme d'une liste d'icône, parfois déroulante pour faire apparaître d'autres outils. 
Les outils auront besoin d'être configurés pour s'adapter à vos besoins. Il faudra donc en permanence avoir en même temps sous les yeux la fenêtre des options d'outil qui peut être placée directement sous les outils (si vous avez choisi d'avoir une boîte à outils suffisamment large) simplement en la faisant glisser dessous.
IV-C - Les menus
Les menus sont nombreux et sont disponibles soit dans le menu principal placé au-dessus de l'image, soit à l'aide du clic droit lorsque la souris est placée sur l'image ou dans certaines fenêtres. Il existe aussi des menus spécifiques à certaines fenêtres qui donnent accès à des fonctions spécialisées.
Alors que les outils vont permettre d'agir directement sur l'image à l'aide de mouvements de souris, les menus vont en général plutôt agir globalement sur l'image ou une zone de l'image définie pour modifier ce qui est présent dans le document. S'il peut être intéressant de connaître tous les outils, il est presque impossible de connaître tous les menus, tant ils sont nombreux, surtout en gardant en tête que chaque menu ouvrira souvent une fenêtre qui contiendra elle-même plusieurs paramètres.

V - Les principales fenêtres
Les fenêtres de Draw sont nombreuses et peuvent être affichées de diverses façons et dans différents contextes.
Certaines fenêtres peuvent être ouvertes en permanence. On les trouve dans le menu Affichage>Barre d'outils. Ce menu donne accès à des fenêtres transversales qui offriront des fonctions nécessaires à divers moments du travail et qui ne sont pas nécessairement propres à un outil.
Les autres fenêtres s'ouvrent de façon ponctuelle, à la demande soit par l'utilisation d'un outil qui nécessite un réglage, soit par le déclenchement d'un menu dont il faudra paramétrer l'action.
N'hésitez pas à parcourir les fenêtres pour voir ce qu'elles affichent. Même si vous ne comprenez pas à quoi elles servent immédiatement, vous verrez leurs points communs, leurs différences et cela vous aidera à mieux identifier les fonctions par la suite en vous imprégnant de l'esprit «_Draw».

VI - Organiser son espace de travail
La clé du succès d'un travail tient souvent dans sa préparation. Dans Draw, disposer les éléments de manière claire et ordonnée facilitera la partie créative. Vous pouvez choisir l'affichage des éléments à dessiner, mais aussi adapter la position et la présentation des fenêtres et des barres d'outils :
	sous forme de bande attachée à la fenêtre principale ;
	sous forme de palette flottante détachée.

Pour détacher une fenêtre, il suffit d'enfoncer la souris sur les poignées à l'extrémité (généralement à gauche) de la barre d'outils et de la glisser pour désolidariser la barre de la fenêtre principale.
Il est aussi possible de caler à nouveau la barre à la fenêtre en l'approchant d'un bord. Cela permet au passage de la placer où bon vous semble, comme sur le côté gauche.
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VII - Zoomer et naviguer
En dessin, le zoom et la navigation dans le zoom facilitent grandement le travail tout en permettant d'avoir une précision maximale, sans effort supplémentaire.
Pour zoomer, vous pourrez utiliser les méthodes suivantes :
	en utilisant la glissière en bas de la barre d'état ;
	en utilisant l'outil loupe qui possède plusieurs options ;
	en passant par Affichage>Zoom et en choisissant l'option qui vous convient dans la fenêtre.
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Pour naviguer dans le document, cela dépend de votre besoin.
	lorsque vous souhaitez vous déplacer à l'intérieur de la page parce que celle-ci n'est pas visible dans son intégralité, vous pouvez utiliser les barres de défilement en bas et à droite ou encore l'outil Déplacer, mis dans le groupe de l'outil Zoom ;
	lorsque vous souhaitez vous déplacer au sein du document, vous pouvez afficher la fenêtre Navigateur Affichage>Navigateur. Cette fenêtre est cependant bien moins utile ici que dans Writer ou Calc.


VIII - Personnaliser ses barres d'outils
L'étape suivante, sera peut-être d'adapter complètement les barres d'outils à vos besoins. Cela ne sera utile que si vous avez un usage intensif du logiciel et pour des tâches régulières nécessitant des fonctions parfaitement identifiées.
VIII-A - Procédure
	Dans le menu des barres d'outils, choisissez Personnaliser la barre d'outils.
	Cliquez sur le bouton Nouveau et donnez un nom à votre nouvelle barre d'outils.
	Elle apparaît alors dans la liste :
	Vous pouvez alors choisir la catégorie de commande par défaut.
	Cliquez sur Ajouter pour faire votre choix. Vous obtenez ainsi au fur et à mesure la barre d'outils qui vous convient le mieux.
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IX - Propriétés du document
Par défaut, Draw se lance avec une page, au format A4 en portrait et des marges déjà définies. Si ce paramètre est certainement le plus courant et qu'il vous sera suffisant dans la plupart des cas, savoir personnaliser le format peut aussi s'avérer utile ou nécessaire dans de nombreux autres cas.
IX-A - Changer les propriétés du document
Avec le développement des outils de recherche avancée, il n'est certainement pas inutile de spécifier quelques métadonnées pour le document. Le nom de l'auteur ou encore mot-clés, peuvent être utiles dans de nombreux contextes, en particulier dans le travail à plusieurs.
Pour modifier les propriétés du document, il suffit d'afficher la fenêtre à partir du menu Fichier>Propriétés. Elle affiche alors ces quelques onglets dont les deux premiers sont les plus utilisés :
	le nom du document apparaît lorsqu'il a déjà été enregistré ;
	la date de création et le nom de l'auteur sont mentionnés un peu plus bas ;
	on trouve aussi le numéro de révision, dont nous parlerons ultérieurement, ainsi que le modèle utilisé s'il en est un ;
	dans l'onglet Description, les informations sont modifiables facilement, il suffira de remplir les champs 
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X - Changement du nom d'auteur
En travaillant à plusieurs personnes sur un document, il peut être intéressant que les contributions de chacun puissent être identifiées. Cela est très fréquent dans le cadre des documents commerciaux : une personne prépare la description des produits, la mise en page est faite par quelqu'un d'autre et le document retourne au précédent pour adaptation. Plusieurs incrémentations du type sont souvent nécessaires avant d'arriver à un consensus. Le nom d'auteur utilisé par défaut est celui qui a été saisi lors de l'installation.
X-A - Procédure
	Allez dans le menu Outils>Options…
	Dans la fenêtre, choisissez LibreOffice>Données d'identité dans la colonne de gauche.
	Changez simplement les valeurs de champs qui sont apparues à droite et le tour est joué.
	Changer les propriétés d'une page.


XI - Changer les dimensions
Pour changer les dimensions d'une page, il suffit d'afficher la fenêtre Paramètres de la page accessible par le menu Format>Page…
Dans cette fenêtre, vous pourrez modifier certains éléments importants comme indiqué ce-dessous.
	La dimension de la page :
	Les marges.
	L'orientation, portrait ou paysage.

Notez que vous changez une de ces options et que votre document contient plusieurs pages, toutes les pages sont indifféremment modifiées.
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XII - Changer l'arrière-plan
Le second onglet de la fenêtre Paramétrage de la page est dédié à la couleur d'arrière-plan. En effet, le fond peut être changé pour une autre couleur (que le blanc par défaut), un dégradé, un motif ou une image.
XII-A - Procédure
	Changez pour l'option que vous souhaitez utiliser.
	La liste des choix pour cette option apparaît.
	Fermez la fenêtre.
	Draw vous demande éventuellement si vous souhaitez appliquer les changements à la page en cours seulement ou à toutes les pages.


XIII - Insérer des pages
À l'instar des logiciels de mise en page comme Scribus, mais à l'inverse d'Inkscape, Draw vous permet de faire des documents de plusieurs pages. Le nombre de pages ne peut être défini à la création du document et c'est donc en fonction des besoins que vous les ajouterez ou supprimerez. Pour ajouter une page, utilisez simplement une des méthodes suivantes :
	utilisez le menu Insertion>Diapo autant de fois que nécessaire ;
	affichez la liste des pages disponibles dans Affichage>Volet Page (s'il n'est pas affiché) et cliquez avec le bouton droit de la souris dans une partie vide du volet et choisissez Nouvelle Page. 
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XIV - Déplacer des pages
Mieux que dans un simple traitement de texte, il est possible de déplacer les pages très facilement et très librement au sein d'un même document.
XIV-A - Procédure
	Affichez le volet page (Affichage>Volet Page).
	Enfoncez le bouton gauche de la souris sur la page (diapo) à déplacer.
	Glissez la souris entre les pages de destination : un petit rectangle doit apparaître pour représenter le fait que vous pouvez valider.
	Si c'est bon, lâchez la souris pour finaliser le déplacement.

Pour déplacer plusieurs pages en une fois, il suffit de toutes les sélectionner en cliquant sur chacune toute en appuyant sur la touche Majuscule (Maj ou Shift).

XV - Supprimer des pages
Le fait d'ajouter des pages peut vous conduire parfois à en créer de trop. Vous aurez peut-être aussi ajouté des pages sur lesquelles vous aurez fait des tests ou positionné des éléments temporairement en vue de leur réutilisation. Ces pages ne sont donc peut-être plus nécessaires dans votre document final.
Pour supprimer une page, cliquez avec le bouton droit dessus (dans la vignette du Volet Page), puis choisissez le menu Supprimer la page.
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XVI - Renommer des pages
Nommer des pages n'a pas d'importance directe, mais peut-être pratique pour structurer votre document et ainsi mieux naviguer aussi dans son contenu, tout en vous aidant à mieux le structurer.
XVI-A - Procédure
	Pour renommer une page, cliquez simplement avec le bouton droit de la souris sur sa vignette dans le Volet page, puis choisissez Renommer la page.
	Dans la fenêtre qui apparaît, attribuez un nom si possible unique en remplacement du nom par défaut correspondant à Diapo suivi d'un chiffre.
	Le nom de la page est visible en étiquette au survol de la page dans le Volet Page, ou encore dans le navigateur (Affichage>Navigateur) accessible par la touche F5. 


XVII - Enregistrer et exporter
Enregistrer est évidemment une étape importante trop souvent négligée. Le menu Fichier>Enregistrer vous permettra de choisir le dossier, d'attribuer un nom d'enregistrement à votre document ou enregistrera les modifications s'il a déjà été enregistré. L'extension utilisée par Draw est ODG pour OpenDocumentGraphic.
XVII-A - Enregistrer comme modèle
Si vous réutilisez éventuellement ce document par la suite pour de futures créations, vous pouvez l'enregistrer sous forme de modèle. Dans ce cas, aucun dossier n'est demandé car LibreOffice gère seul le dossier de ses modèles.
Par connaître les dossiers potentiellement utilisés ou les modifier, allez dans Outils>Options>LibreOffice>Chemins.
XVII-B - Exporter dans d'autres formats
Il est fort probable que vous aurez besoin de fournir tout ou partie de votre document. Peut-être à des collaborateurs ou encore pour le mettre à disposition sur Internet.
Comme tous les modules de la suite LibreOffice, il est possible d'exporter en PDF. Mais de nombreux autres formats sont à disposition parmi lesquels :
	des formats vectoriels comme EPS (qui peut être réutilisé dans Scribus), ou SVG (réutilisable dans Inkscape et Scribus, voire même dans FontForge) ;
	des formats bitmap comme le JPG, le PNG ou le TIF.

Le choix du format repose sur l'objectif final ou la compatibilité avec un autre logiciel. Veuillez demander à vos collaborateurs ce qu'ils souhaitent ou renseignez-vous sur le logiciel de destination. Si toute la chaîne de production fonctionne avec LibreOffice, préférez le format natif.

XVIII - Les outils de dessin de base
Grâce aux outils mis à disposition par Draw, chacun peut facilement dessiner des formes dans les pages pour produire un résultat visuel riche et varié. Ces formes peuvent être combinées par superposition ou des fusions de manière à créer des formes plus complexes.
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Il n'est pas utile de connaître 100 outils pour arriver à faire des mises en page intéressantes. En général, quelques formes simples comme rectangles, cercles, bien paramétrées et joliment disposées suffisent. Cependant, LibreOffice Draw met de nombreuses formes à disposition de manière à faciliter et accélérer le travail.
Ces formes sont classées par catégories en fonction de leur utilité. Certaines d'entre elles se retrouveront donc dans plusieurs catégories. La barre de dessin donne un accès rapide à toutes les catégories, mais il est possible de détacher celle qui sera la plus utilisée de manière à limiter le nombre de clics.

XIX - Paramétrer des formes par défaut
Les formes mises à disposition, même si elles sont nombreuses, ne peuvent pas convenir à tous les besoins et à tous les goûts. Comme dans Inkscape, les formes ont donc des propriétés modifiables pour affiner le dessin. Ces propriétés peuvent être modifiées à volonté.
Pour reconnaître comment agir dessus, il suffit de regarder attentivement la façon dont les poignées sont constituées autour et sur la forme sélectionnée à l'aide de l'outil de sélection :
	les poignées bleues servent majoritairement à redimensionner la forme ;
	les poignées jaunes à modifier la structure de la forme ; ce sont elles qui nous intéressent ici.
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Cette façon de procéder est très pratique et réactive. Cependant, toutes les formes ne disposent pas de possibilité de modifications de ce genre.

XX - Transformer les objets
Transformer va consister à appliquer des opérations prédéfinies à une forme. Les opérations les plus fréquentes sont les redimensionnements et les rotations.
XX-A - Redimensionner
Pour redimensionner un objet, il suffit de tirer sur une poignée bleue à l'aide du bouton gauche de la souris :
	les poignées situées au milieu des côtés étireront la forme du côté où la poignée est tirée ;
	les poignées placées aux angles redimensionneront à la fois la largeur et la hauteur.

En procédant ainsi, le fait de redimensionner déforme les proportions de la forme initiale. Pour conserver les mêmes proportions, il suffit d'appuyer sur la touche Maj pendant le glissé de redimensionnement.
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XX-B - Rotation
La rotation fonctionne bien différemment. Pour faire tourner la forme sur elle-même, il faudra activer l'outil spécifique placé dans le groupe Effets de la barre de dessin.
En cliquant sur l'outil, de nouvelles poignées, rouge sombre, apparaissent :
	aux angles, vous verrez en approchant que le curseur de la souris se transforme en flèche tournant en cercle sur elle-même : il s'agit des poignées de rotation. Obtenez le même résultat à partir du menu Modifier>Tourner ;
	au milieux de côtés, le curseur de la souris prend la forme de deux demi-flèches allant en sens opposés : il s'agit de l'option d'inclinaison.

[image: ]
Si vous le souhaitez, vous pouvez modifier la position de l'axe qui apparaît sous la forme d'une petite cible au centre. Vous pourrez ainsi mieux contrôler, selon les cas, la façon dont la transformation doit s'effectuer.

XXI - Mieux contrôler la transformation
S'il suffit d'utiliser la souris pour transformer un objet, cela s'avère efficace et rapide dans la majorité des cas. Cependant, si l'opération doit être répétée à l'identique plusieurs fois, les problèmes vont commencer à apparaître. Dans ces cas et dans d'autres cas, il sera préférable d'effectuer la transformation de façon plus con­trôlée soit en utilisant des touches clavier, soit par le biais de données géométriques.
	La touche Ctrl sert à faire tourner la forme par incréments réguliers. Appuyez sur la touche pendant que vous effectuez la transformation à l'aide de la souris.

			Attention à bien prendre les poignées, car cette touche sert aussi à faire une copie de la forme par un déplacement lorsque la souris est sur la forme elle-même.
	La fenêtre Format>Position et taille va offrir de nombreuses solutions pour faire des transformations chiffrées.

En utilisant l'onglet Rotation et Inclinaison de la fenêtre, vous verrez que le cumul des options peut parfois rendre les choses difficiles et que l'ordre dans lequel les transformations sont validées compte. En particulier, vous remarquerez déjà qu'en tournant ou inclinant, la valeur de position horizontale a été affectée puisque le côté gauche de l'objet a été légèrement déformé.
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XXII - Ajouter du texte
Le texte fait souvent partie des dessins et autres produits de communication dessinés avec Draw. Il offre d'ailleurs à ce niveau des options très respectables qu'il a parfois mises à disposition avant des logiciels bien plus réputés du secteur du dessin vectoriel.
Il existe ici plusieurs façons d'insérer du texte et de le paramétrer. Commençons par les choses simples :
	un double-clic sur une forme géométrique activera une possibilité d'écrire du texte sur la forme. Dans ce cas, le texte est centré sur celle-ci et il ne reste pas nécessairement dans l'espace qu'elle définit et peut en déborder ;
	l'utilisation de l'outil Texte dédié permet d'avoir un meilleur contrôle sur le résultat. Une zone spécifique est créée soit en cliquant (elle s'allongera seule et automatiquement au fur et à mesure de l'écriture) soit en traçant un rectangle (le texte s'y adaptera).

Dans tous les cas, la barre de propriété du texte est disponible au-dessus de la zone de dessus pour pouvoir changer l'aspect du texte.
Enfin, les outils de modification mentionnés précédemment s'appliquent aussi au texte, de la même façon. Cela fait de l'outil Texte un réel outil de création qui peut être utilisé de façon libre et créative à l'intérieur des documents.
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XXIII - Fusionner des objets
Si les formes de base fournies par Draw sont assez nombreuses, elles ne suffiront pas toujours à vous permettre de tout dessiner. Draw dispose de commandes permettant de créer des formes évoluées en fusionnant des formes simples.
Il y a trois commandes principales qui sont accessibles par le menu Modifier>Formes :
	fusionner : prends les deux formes et les combines en une seule. La forme résultante occupe la somme des deux formes originelles :
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	soustraire : prend une forme et découpe la forme placée en dessous. La forme résultante est donc nécessairement plus petite :
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	intersecter : fusionne les deux formes de façon à garder uniquement la zone de recouvrement des formes sélectionnées :
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Pour que la fusion fonctionne au mieux, les formes doivent si possible se superposer et être sélectionnées au préalable. Si le nombre de formes sélectionnées est supérieur à deux, le résultat n'est pas garanti.
XXIII-A - Procédure
	sélectionnez deux ou plusieurs formes selon vos besoins ;
	appliquez la fusion sur les formes sélectionnées ;
	adapter les couleurs.

Dans tous les cas :
	si les formes sont de couleurs différentes, la couleur conservée dans la forme finale est celle de la forme inférieure ;
	remarquez comment la structure des poignées bleues a été modifiée, cela sera utile par la suite pour contrôler encore mieux l'aspect final de la forme.

Les combinaisons peuvent être faites en cascade ce qui donne finalement une très grande quantité de possibilité. À ce niveau, seule la créativité et l'imagination peut vous servir de ressort.

XXIV - Changer la superposition des objets
Dessiner des formes n'est qu'une petite partie du travail de création. Disposer, arranger, organiser mais aussi attribuer élégamment couleur, contour ou autres propriétés visuelles va influencer grandement l'aspect final et la qualité du document.
Comme nous venons de le voir avec les options de fusion, l'ordre de superposition des objets n'est pas qu'une option de présentation, mais aussi parfois une nécessité.
Par défaut, toute nouvelle forme créée dans Draw vient se placer sur un niveau de superposition supérieure à la précédente, et cela même si les formes ne recouvrent pas une zone commune.
Dans Draw, on peut accéder à ces fonctions par le menu Modifier>Disposition, le clic-droit>Organiser ou encore le groupe Disposer dans la barre de dessin. Les opérations courantes pour changer la superposition (on dit parfois disposition) sont les suivantes :
	descendre d'un niveau  : envoyer vers l'arrière ;
	monter d'un niveau : envoyer vers l'avant ;
	descendre à l'arrière-plan : envoyer à l'arrière ;
	monter au premier plan : envoyer à l'avant.

Ces options sont celles que l'on retrouve régulièrement dans de nombreux logiciels. Draw dispose aussi des fonctions suivantes très pratiques, car relatives entre les objets sélectionnés :
	devant l'objet : qui va placer l'objet le plus bas dans la pile de sélection au-dessus des autres ;
	derrière l'objet : qui va placer l'objet le plus haut dans la pile de sélection au-dessous des autres ;
	inverser les objets, qui inversent donc la position des objets sélectionnés.

S'agissant de changer la position verticale d'objets les uns par rapport aux autres, il est impératif dans ces dernières options que deux objets, au moins, soient sélectionnés.
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XXV - Aligner les objets entre eux
Il est souvent nécessaire de positionner certains objets de la mise en page par rapport à d'autres. En général, il s'agira de les centrer ou de les placer les uns contre les autres sans risque de décalage.
L'utilisation de ces commandes est en particulier pratique lorsque certains objets de référence ont déjà été correctement positionnés et que d'autres devront être placés relativement aux premiers. D'un simple clic, tous les objets sélectionnés iront se positionner par rapport à cet objet de base conformément au bouton cliqué. Il conviendra donc de faire bien attention à la sélection et au choix de l'option.
Les deux fonctions principales de Draw pour gérer ces déplacements vont être :
	alignement par le biais du groupe du même nom dans la barre de dessin ou dans le menu Modifier>Alignement. Pour deux ou plusieurs objets entre eux ou par rapport à la page, l'alignement va globalement tenter de mettre les objets dans un endroit identique, en fonction du côté choisi ;
	répartition lorsque plus de deux objets sont sélectionnés et qu'il s'agit de gérer en même temps la distance entre les objets, la répartition va tenter d'espacer les objets de façon identique relativement à l'espace global de la sélection. 
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XXVI - Guider les déplacements
En ce qui concerne le positionnement, il est toujours plus facile de bien faire du premier coup. Pour aider à cela, quelques options sont disponibles. Elles impliquent d'avoir une bonne vue de ce qui doit être fait et de la suite d'étapes à réaliser, un peu comme dans le cas des options de fusion. Faire les choses à l'envers ne sera pas dramatique mais fera perdre à ces options une bonne partie de leurs avantages.
XXVI-A - Utiliser le clavier pour verrouiller le déplacement
Lorsqu'une forme est créée et que d'autres formes du même type doivent être utilisées, il est possible de les copier en appuyant sur la touche Ctrl lors d'un déplacement. Si en même temps, la touche Maj est enfoncée, le déplacement de la copie sera contraint à reste sur la même ligne que l'original. Cela évite d'avoir recours aux alignements par la suite.
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XXVI-B - Utiliser grilles, repères et magnétisme
Grilles et repères sont des lignes qui vont aider au placement en servant de référence.
La grille est un quadrillage complet et régulier de la page. Le menu Affichage>Grille>Afficher la grille, la fait apparaître et Affichage>Grille>Aligner sur la grille, permet aux objets de s'y accrocher lors d'un déplacement.
Les repères sont des traits placés « manuellement » sur la page : pour les créer, il suffit d'enfoncer le bouton de la souris dans une règle à gauche ou en haut et de glisser. Relâchez pour le placer. Le menu Affichage>Repères>Afficher les repères, permet de les afficher ou de les masquer et Affichage>Repères>Capturer aux repères, permet d'y caler les objets.
Le menu Insertion>Insérer un point/une ligne de capture… permet d'ajouter un repère à un emplacement précisément défini.
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XXVII - Changer la couleur d'un objet
Les couleurs sont des éléments importants de la mise en page et il va être important de pouvoir l'appliquer facilement aux bons objets.
La solution la plus utilisée pour changer la couleur est d'avoir recours à la barre d'options placée au-dessus de la zone de dessin. Cette barre permet de changer la couleur du contour, ses propriétés et la couleur intérieure de la forme.
	pour le remplissage, il suffit de développer la liste déroulante Couleur pour choisir le type parmi Invisible (sans couleur), Couleur, Dégradé, Hachures et Bitmap (image). Le champ voisin s'active et les couleurs disponibles sont affichées ;
	dans le cas du contour, la méthode est identique sauf que la liste des types de trait est constituée de différentes formes de pointillés.

Enfin, s'il s'agit d'une ligne simple à modifier, la couleur de remplissage pourra s'avérer inutile. En revanche, l'utilisation de flèches (3e bouton de la barre) pourra prendre effet. La colonne de gauche se destinera plutôt aux points de début et l'autre aux points de fins.
Il devient alors presque simple de créer des schémas dans Draw.
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Si le fait de dérouler des listes vous amuse peu, vous pouvez afficher en permanence les couleurs disponibles. Dans le menu Affichage choisissez Barre des couleurs. En cliquant sur une couleur de cette barre avec le bouton gauche vous appliquerez la couleur au remplissage et, avec le bouton droit, au contour de la sélection (il doit bien sûr disposer d'une épaisseur et d'un type).
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Pour accéder à plus d'options d'un seul coup, vous pouvez utilisez les fenêtres Ligne et Remplissage à l'aide du menu contextuel ou Format.

XXVIII - Utiliser des nuanciers
Les couleurs fournies par défaut dans LibreOffice peuvent très bien ne pas faire l'affaire :
	elles ne correspondent pas à votre charte graphique ;
	elles ne vous conviennent pas ;
	elles sont trop nombreuses et vous perdez du temps à trouver les deux ou trois que vous aimeriez utiliser ;
	elles sont trop peu nombreuses et vous vous sentez limité.

Dans tous ces cas, et peut-être dans d'autres, il faudra personnaliser la liste des couleurs ou en créer de nouvelles. Cela peut être fait de deux endroits :
	la fenêtre d'options Outils>Options>LibreOffice>Couleurs ;
	la fenêtre des couleurs, par exemple dans la fenêtre Remplissage vue précédemment.

XXVIII-A - Procédure à suivre
	Sélectionnez une couleur.
	Attribuez-lui un nouveau nom et cliquez sur Éditer.
	Choisissez votre couleur dans le spectre ou en saisissant ses références chiffrées.
	Supprimer les couleurs inutiles.
	Cliquez sur le bouton d'enregistrement et donnez un nom à votre nouveau nuancier…
	Qui devient disponible dans vos listes.

Les hachures et dégradés peuvent être modifiés de façon quasi similaire.
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XXIX - Utiliser des styles de forme
S'il vous arrive d'utiliser très régulièrement le même type de mise en forme, autant la définir une bonne fois pour toutes et ne plus y revenir. Les styles de forme, comme les styles de texte dans Writer, vont permettre de mémoriser un ensemble de critères définissant l'aspect graphique de la forme, de manière à :
	les réutiliser plus facilement ;
	limiter le taux d'erreur et d'approximation ;
	éviter les oublis de propriétés et gagner en consistance ;
	mettre à jour plus facilement.

On voit aisément que l'utilisation de styles permettra de gagner un temps précieux et d'augmenter la qualité globale, sans pour autant réduire la créativité.
Pour créer un style, c'est très simple et deux façons s'offrent à vous, toutes deux passant par la fenêtre Style et formatage du menu Format, habituellement placé à l'extrême droite de la fenêtre du logiciel :
	soit vous créez le style à partir de l'objet sélectionné sur la page. Ce cas est surtout utile lorsqu'il s'agit d'un nouveau document et que le résultat est le fruit d'une recherche graphique immédiate. Cliquez sur le bouton Style d'image (le premier à gauche de la fenêtre, puis sur Nouveau Style à partir de la sélection) ;
	soit vous créez un style à partir de zéro. Ce cas convient lorsque vous savez mieux ce que vous devez réaliser, que vous avez l'habitude de vous organiser ou que vous êtes guidés par une charte graphique. Cliquez sur le bouton Style d'image (le premier à gauche de la fenêtre, puis clic droit sur une zone vide de la fenêtre et choisissez Nouveau. Modifiez les propriétés et enregistrez.

Pour appliquer un style, il suffit de sélectionner la ou les formes sur lesquelles l'appliquer, puis de cliquer sur le nom du style dans le volet Style et formatage.
Pour modifier un style déjà créé, il est possible de le faire à partir d'une forme sélectionnée en choisissant le bouton Actualiser, le style placé à l'extrême droite du volet Style et formatage ou d'utiliser un clic-droit sur le style, et choisir modifier. Une fois le style changé, toutes les formes auxquelles il est appliqué seront adaptées en fonction.
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XXX - Enrichir avec des formes uniques
Le travail avec les formes géométriques et les quelques outils par défaut, malgré la possibilité de les combiner ne sera peut-être pas non plus suffisant. Dans ce cas, il faudra mouiller la chemise et passer au dessin proprement dit, celui qui fera appel au talent caché ou non que vous possédez. Nous passons alors à un niveau de personnalisation important, ce qui nous donne aussi l'occasion de voir l'utilisation d'image dans le cadre de ce logiciel de dessin vectoriel et certaines autres options pratiques et productives.

XXXI - Courbes de Bézier
Les courbes de Bézier sont des formes de courbes possédant quatre poignées de contrôle et qui ont l'avantage de constituer un standard dans les logiciels de dessin vectoriel. Illustrator et Inkscape les maîtrisent parfaitement et même Scribus en dispose. L'outil de ce dernier est d'ailleurs très proche en manipulation de celui de Draw.
Bien qu'on les nomme « courbes », ces outils permettent aussi de tracer des droites. On devrait peut-être les appeler ou considérer la droite comme un cas particulier de la courbe (une courbe plate).
Vous trouverez les outils de courbes de Bézier dans le groupe ligne de la barre de dessin. Il s'agit habituellement du 7e bouton au départ de la gauche (celui qui est placé après A).
Les différents outils du groupe sont décrits ci-dessus.
La ligne à main levée est un cas un peu spécial de l'outil. En l'activant, vous pourrez glisser la souris en enfonçant le bouton gauche. Vous tracerez alors une ligne simple, mais ne contrôlerez pas bien son aspect. Vous serez surtout dépendant des caprices de la souris. Bref, ce n'est certainement pas l'outil que vous utiliserez le plus si vous cherchez à obtenir un résultat précis.
En lâchant la souris, vous verrez parfaitement apparaître les points générés par le logiciel. Si vous le souhaitez, vous pouvez les déplacer à l'aide de la flèche blanche.
Lors du déplacement de nouvelles poignées, reliées à la première, vont apparaître. Celles-ci aussi peuvent être modifiées. Elles déformeront l'aspect de la courbe placée du côté du point manipulé.
Remarquez que le curseur change d'aspect selon les poignées que vous manipulez.
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Ainsi, chaque ligne est composée de plusieurs courbes, chacune encadrée par deux poignées de position donnant accès à deux poignées d'inflexion.

XXXII - Les polygones
S'il est possible de tout dessiner de la sorte, cela ne sera pas toujours le plus simple ni le plus rapide. Passons donc aux autres outils du groupe :
	l'outil polygone à 45° va permettre de tracer des lignes horizontales et verticales, ou encore, seulement obliques. Cet outil est très pratique pour dessiner des schémas simples ou certains motifs ;
	l'outil polygone permet de dessiner toute forme composée de ligne droite, quels que soient les angles et inclinaisons souhaités.

Comme précédemment, les points qui composent ces formes sont modifiables. Vous remarquez que dans ces deux derniers cas, aucune poignée n'apparaît lors d'un clic sur une poignée de base. Cela s'explique par le simple fait que ces autres poignées servent à gérer l'aspect de la courbe et que dans le cas des polygones, il n'y a pas de courbe.
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XXXIII - Les courbes
Il reste enfin les courbes proprement dites. Il sera alors possible de dessiner presque tout ce qui est possible. Il faudra alors cependant avoir une bonne idée du résultat souhaité, une bonne maîtrise de la souris et un peu de sang-froid.
XXXIII-A - Procédure
	Enfoncez le bouton gauche de la souris à l'emplacement où vous souhaitez voir votre courbe débuter. Glissez dans la direction que doit prendre la courbe. Une ligne droite apparaît, c'est normal.
	Lâchez le bouton lorsque cela vous semble bon puis déplacez votre souris à un autre emplacement : là par où vous souhaitez voir votre courbe passer. Il est bien important de visualiser en esprit le résultat souhaité. Mais pas d'inquiétude, le résultat sera modifiable.
	Enfoncez à nouveau le bouton gauche et glissez la souris. La courbe commence alors à apparaître. Déplacez la souris en tenant compte de l'aperçu que vous donne le logiciel sans perdre de vue ce que vous souhaitez.
	Reprenez les points 2 et 3 autant que nécessaire.
	Double-cliquez pour terminer votre courbe. 
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XXXIV - Modifier la forme ou la courbe de Bézier
Il peut parfois être utile de s'aider en affichant la grille ou en traçant des repères au préalable. Cela peut aider grandement à obtenir des courbes plus régulières.
Si toutefois le résultat ne vous satisfait pas complètement, vous pouvez toujours modifier la courbe ainsi dessinée, par exemple, en cliquant avec le bouton droit sur la courbe sélectionnée et en choisissant Éditer les points.
Avec toutes ces options qui permettent de modifier la nature des poignées, d'anguleuses à courbes, de redessiner les courbes et de manipuler les points, tout devient possible avec un peu de temps.
Tout autant que les options disponibles, il est important d'avoir une idée du résultat en tête pour anticiper les différents moments de la production du dessin. Essayons un petit exemple. Nous utiliserons une flèche fournie par Draw, dont nous modifierons une extrémité et que nous courberons.
XXXIV-A - Procédure
	Dessinez la flèche en prenant simplement la première ou la seconde de la barre d'outil flèche de la barre dessin. Cliquez avec le bouton droit sur la forme et choisissez Convertir > En Courbes. La fenêtre Édition de point doit apparaître, sinon affichez-la à l'aide du clic-droit > Éditer des points.
	Cliquez sur le bouton Insérer des points puis sur le milieu de la partie du gauche de la flèche. Déplacez alors la nouvelle poignée vers la droite. Remarquez que les deux segments attenants à ce point sont légèrement courbes.
	Pour mieux contrôler ces segments, cliquez sur Points d'inflexion et adaptez éventuellement la position des poignées de contrôle.
	Cliquez sur un des points de la partie supérieure de la queue de la flèche pour afficher les poignées.
	Puis déplacez la poignée directrice qui longe la forme de manière à courber cette queue.
	Faites la même chose avec le point inférieur et tout autre point qu'il vous semble bon de modifier. 
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XXXV - Utiliser les connecteurs
On retrouve ici le principe des points et des courbes dans une tout autre fonction. Il va s'agir ici d'aider à la création de relation entre forme, par exemple, dans le cas des schémas et diagrammes.
Les connecteurs sont des sortes de lignes qui vont s'accrocher à certains points d'une forme. En cas de déplacement de cette forme, la ligne s'adapte pour suivre.
XXXV-A - Procédure
	Dessinez une première forme géométrique.
	Puis une seconde.
	Prenez l'outil connecteur et choisissez une forme de connecteur dans la liste. Approchez votre souris de la forme sélectionnée : des poignées en forme de croix doivent apparaître, les points de collage.
	Enfoncez le bouton gauche sur une croix dans cette première forme puis glissez jusqu'à une croix de l'autre forme ; elles vont apparaître lorsque votre souris s'approchera. Une fois le connecteur positionné, chaque extrémité est représentée par un point rouge.

Il est alors facile de changer la position de la flèche par rapport à la forme. Pour cela, il suffit de prendre l'outil de sélection (flèche blanche) et de glisser la fin du connecteur de son point de collage vers un autre. La forme de la flèche se redessine alors immédiatement.
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XXXVI - Personnaliser les connecteurs
Il existe différents types de connecteurs applicables.
Les types de connecteurs sont :
	normal/standard ;
	linéaire ;
	incurvé ;
	direct.

Et chaque type se décline en trois préréglages :
	sans flèche ;
	flèche à la fin ;
	flèche de chaque côté.

XXXVI-A - Procédure
	Vous dessinez le connecteur avec l'outil choisi.
	Pour modifier le type après l'avoir créé, il faut afficher les propriétés de la forme (clic droit > Connecteur) et changer le type (première liste déroulante).
	Pour changer le préréglage, il suffira d'utiliser les options du trait comme pour toute autre forme ou ligne.


XXXVII - Modifier la forme du connecteur
Les connecteurs disposent de plusieurs propriétés qui peuvent être modifiées librement. Hormis le type, on trouvera dans la fenêtre de propriétés de connecteur :
	décalage de ligne ;
	interlignage.

Dans les deux cas, utiliser les poignées rouges placées au milieu des segments du connecteur semble plus simple et plus intuitif, à moins qu'il n'y ait un besoin réel d'avoir une régularité, auquel cas, la saisie de valeur pourra s'avérer pratique.
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XXXVIII - Définir les points de collage
Les options par défaut des connecteurs sont là pour favoriser un travail rapide. Il pourra cependant être nécessaire de personnaliser encore plus la façon dont le connecteur agit avec la forme. Dans ce cas, il s'agit de contrecarrer le comportement initial ou de le compléter.
Cela passera par la barre d'outil Points de Collage que l'on peut faire apparaître à l'aide du bouton Point de collage de la barre dessin (icône : tube de colle).
XXXVIII-A - Accrocher le connecteur à l'endroit voulu
Par défaut, les points de collage sont placés au centre des côtés ou aux angles, selon les formes utilisées. Si ce paramètre convient dans la plupart des cas, cela devient encombrant si on multiplie les connecteurs, ils s'accrochent alors tous au même point :
	pour ajouter un connecteur, cliquez sur le premier bouton de la barre Points de collage ;
	cliquez ensuite sur votre forme à l'endroit où vous souhaitez que la connection s'établisse ;
	si votre forme est vide de couleur, il faudra cliquer sur le contour, sinon, tout emplacement peut être utilisé.

Point de collage Relatif permet d'associer le point à la forme, si bien qu'en cas de redimensionnement, le point suivra la forme correctement. Il s'agit de l'option activée par défaut.
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XXXIX - Définir le sens de la flèche de connexion
Le sens de la flèche de connexion peut être contrôlé à l'aide des options de la barre Points de Collage. Ces quatre options insérées à droite du bouton Insérer un point de collage permet de faire varier réellement l'aspect du connecteur et son mouvement dans l'espace.
XXXIX-A - Procédure
Pour modifier l'orientation de la flèche :
	sélectionnez la forme contenant les points de collage, affichez la barre Point de Collage puis cliquez sur le point de collage à modifier ;
	cliquez sur un bouton permettant de changer l'orientation de la flèche ;
	en déplaçant la forme, vous vous rendrez bien compte de l'impact de tels choix.

L'utilisation du connecteur permet de réaliser de nombreuses formes d'organigrammes simplement et permet de garder la jonction entre les flèches et les formes, même en cas de déplacement.
Il s'agit d'un outil favorisant la productivité et la lisibilité, au détriment de la forme graphique de l'organigramme qui ne pourra être créée qu'à partir de formes simples ou dessinée avec des courbes de Bézier, mais sans disposer des mêmes options de liaison automatique des formes.

XL - Utiliser des objets variés
Dans les catégories de documents à réaliser, prenons par exemple les cartes de visite, flyers ou poster (commerciaux ou scientifiques), il n'est pas rare d'avoir à importer des images externes soit en fond, soit comme illustration à un propos. Ces images peuvent être de différentes sources et de différents types et nous nous proposons ici de voir quelques cas de figure basés sur l'utilisation de photos, de documents OpenOffice, en particulier sur les tableaux et diagrammes qui peuvent facilement être passés de Calc à Draw, ou encore des sources de logiciels externes.

XLI - Utiliser des photos
Il est bien sûr possible d'importer des photos dans un document Draw, comme dans tous les modules de la suite LibreOffice. Le menu de base pour effectuer cette action est Insertion>Image>À partir d'un fichier… LibreOffice prend en charge de nombreux formats d'images et vous ne devriez pas être trop limité de ce point de vue.
XLI-A - Procédure
	Placez-vous sur la page qui doit accueillir votre photo.
	Utilisez le menu Insertion>Image>À partir d'un fichier… ou cliquez sur le bouton À partir d'un fichier dans la barre de dessin.
	La fenêtre qui s'ouvre permet de naviguer dans les fichiers pour retrouver l'image que vous souhaitez insérer. Si votre dossier de destination contient beaucoup d'images et que vous n'y voyez pas clair dans la liste vous pouvez :
	Si au contraire vous doutez du nom de l'image, cliquez sur Aperçu de manière à voir l'aspect des photos s'afficher à droite de la zone de navigation ;
	Enfin, cliquez sur Ouvrir pour l'insérer dans la page.

	choisir le type, si vous le connaissez, de manière à n'afficher que les images du type qui vous intéresse ;
	Écrire le début du nom de l'image dans le champ éditable placé au-dessus de la zone principale de la fenêtre (ou que vous pouvez rendre éditable en cliquant sur le petit crayon placé à droite du fil de navigation) ;

L'option « Lier » permet de faire en sorte que LibreOffice se souvienne de l'emplacement d'origine de la photo, si bien qu'en cas de changement suite à une retouche, elle soit automatiquement prise en compte dans votre document Draw.
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XLII - Modifier la présentation de l'image
Une fois l'image importée, il va souvent falloir l'adapter aux besoins. Parmi les opérations fréquentes, on retrouve le fait de changer la dimension, ou encore l'orientation. Si vous avez déjà effectué ces opérations sur des formes géométriques, cela sera facile, car les manipulations sur les photos sont les mêmes.

XLIII - Remerciements
Ce manuel vous est offert par Floss Manuals.
Je remercie également jacques_jean pour sa relecture attentive et assidue.
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